PerkinElmer Informatics Support Forum
Decrease font size
Increase font size
Topic Title: "Not default editor" everytime I start ChemBioDraw
Topic Summary:
Created On: 12/3/2014 2:06 PM
Status Post and Reply
Linear : Threading : Single : Branch
Topic Tools Topic Tools
View topic in raw text format. Print this topic.
 12/3/2014 2:06 PM
User is offline View Users Profile Print this message


CBGb

Posts: 3
Joined: 12/3/2014

Every time I start ChemBioDraw, I get the message

ChemBioDraw Ultra 14.0.0.117 is not the default editor for its own files. Would you like to update the file associations now?

I always click "Yes", but the message returns every time I restart. Is there a fix?

 12/12/2014 9:37 AM
User is offline View Users Profile Print this message


CS RNA

Posts: 631
Joined: 2/25/2009

Please do the following:

1. Open Control Panel from the Start menu

2. Browse for "Default Program" (if you are not able to view the "Default Program" then you need to set the Category as "Small Icons"

3. Click on the "Associate a file type or protocol with a program"

4. Scroll till you get the file type .cdx (cds and cdxml)

5. Select the .cdx file type and click on the "Change program" button, it will open the "Open with" dialog box; click on the "Browse" button and select the ‘ChemDraw.exe' present at "C:\Program Files (x86)\CambridgeSoft\ChemOffice2014\ChemDraw" folder

6. Now click the Open button and then click the OK button in the "Open with" dialog box.

Does this help?

Note: You need to do the same steps for cds and cdxml file types if the file association is different.

If you still need any assistance, please visit http://www.cambridgesoft.com/contact/support/ to submit a ticket, to get assistance from our Tech Support Team



-------------------------

- PKI Support

 12/12/2014 10:19 AM
User is offline View Users Profile Print this message


CBGb

Posts: 3
Joined: 12/3/2014

No. The control panel had "ChemBioDraw 14" as the default. I browsed and found ChemDraw.exe as instructed and set it as the default. No change in behavior.

 12/15/2014 6:43 AM
User is offline View Users Profile Print this message


CS RNA

Posts: 631
Joined: 2/25/2009

Assuming you got the following warning message:

ChemBioDraw Ultra…14.0.x is not the default editor for its own files.

Would you like to update the file associations now?

If so, just uncheck the “Always perform check when starting the program’ checkbox and click the “Yes” button

Does this help?

If not, please do the following.

Click on the Start menu and type “regedit”, and open the regedit tool and expand

HKEY_CLASSES_ROOT\

Browse for the folder “.cdx”, select the folder, right click and choose delete from the context menu.

Now double click over the .cdx file, it will ask you to choose the application to open the file.

Choose ‘Select a program from a list of installed programs” option and click OK

This will open the “Open with” dialog box, click on the Browse button and select the ‘ChemDraw.exe' present at "C:\Program Files (x86)\CambridgeSoft\ChemOffice2014\ChemDraw" folder

Now click the Open button and then click the OK button in the "Open with" dialog box.

Make sure that “Always use the selected program to open this kind of file” checkbox is checked.

This will allow the ChemBioDraw/ChemDraw application to open the cdx file and also you got a warning message.

ChemBioDraw Ultra…14.0.x is not the default editor for its own files.

Would you like to update the file associations now?

Make sure “Always perform check when starting the program’ checkbox is not selected

Just click the “Yes” button.



-------------------------

- PKI Support



Edited: 12/15/2014 at 9:35 PM by CS RNA
 12/15/2014 10:36 AM
User is offline View Users Profile Print this message


CBGb

Posts: 3
Joined: 12/3/2014

Still behaving the same. The folder I found was '.cdx' not 'cdx'. I deleted it and all of its subfolders. When I double clicked on a .cdx file, I did not get the 'Select a program from a list of installed programs' message. Instead it just ran Chemdraw14 and gve me the same message.

 12/15/2014 9:35 PM
User is offline View Users Profile Print this message


CS RNA

Posts: 631
Joined: 2/25/2009

If you still need any assistance, please visit http://www.cambridgesoft.com/contact/support/ to submit a ticket, to get assistance from our Tech Support Team



-------------------------

- PKI Support

FuseTalk Basic Edition v4.0 - © 1999-2019 FuseTalk Inc. All rights reserved.