PerkinElmer Informatics Support Forum
Decrease font size
Increase font size
Topic Title: ChemOffice 15 still no support for high DPI displays?
Topic Summary:
Created On: 5/28/2015 10:13 AM
Status Post and Reply
Linear : Threading : Single : Branch
Topic Tools Topic Tools
View topic in raw text format. Print this topic.
 5/28/2015 10:13 AM
User is offline View Users Profile Print this message


jeroenvs

Posts: 1
Joined: 4/24/2012

Today I installed ChemOffice 15 on my asus zenbook
4k 13.3" display.

I was shocked that the icons in ChemDraw were still practicly invisible. High DPI displays are not a novelty anymore.
This issue was raised here over a year ago.
Is there any update on a fix for this or should I start looking for alternatives?

 5/29/2015 11:35 AM
User is offline View Users Profile Print this message


CS RNA

Posts: 599
Joined: 2/25/2009

We are aware that our software does not display properly on high DPI displays.

Our R&D team is actively working on fixing this issue because it has been brought up many times. We hope to be able to provide this capability shortly.

Please monitor our news feed for any update on this issue http://www.cambridgesoft.com/services/SupportNews/



-------------------------

- PKI Support

 5/31/2016 8:29 PM
User is offline View Users Profile Print this message


greg

Posts: 14
Joined: 2/5/2010

It's been over a year on this post and the problem isn't resolved? This is a big issue for people who use laptops such a surface pros. Please respond.

 6/1/2016 3:01 PM
User is offline View Users Profile Print this message


drhilary

Posts: 2
Joined: 6/1/2016

I am also having an issue when I paste into word or powerpoint using Windows 10 and Chemdraw professional 15 that I suspect is DPI related. The chemdraw drawings are cut off on the right and bottom. When I double clip to edit the drawing in chemdraw, this does not fix the issue. Is there a work around for this issue?

 6/1/2016 7:57 PM
User is offline View Users Profile Print this message


drhilary

Posts: 2
Joined: 6/1/2016

 7/11/2016 4:11 PM
User is offline View Users Profile Print this message


jtirado

Posts: 1
Joined: 2/25/2011

Is there a hope for a solution in the near future? Maybe a "ChemDraw Huge" theme?
My 13.3" laptop is up to 3200x1800 resolution, which means that using the "ChemDraw Large" theme puts the toolbar icons size at 3-3.5 mm size ...
The solution for most adobe programs at http://www.danantonielli.com/a...high-dpi-displays-fix/ will let me see the buttons quite well, but unfortunately makes the drawings very, very small in a large bounding box so they cannot be resized appropriately.
 10/27/2016 11:53 PM
User is offline View Users Profile Print this message


chigman

Posts: 3
Joined: 3/4/2014

Is there a fix for this issue yet? Just installed ChemOffice15 on surface book and can barely make out the icons.

 10/28/2016 4:06 PM
User is offline View Users Profile Print this message


AgentK7

Posts: 5
Joined: 10/28/2016

This is a huge issue on the Surface Pro and other high DPI displays. I have to go close to the screen to clearly make out the icons, even with this large theme! This makes me quite sad as I was looking forward to using the pen to draw structures quickly using the touchscreen for my chemistry degree, but it's hard to see the icons, let alone touch the correct ones. Resizing/rotating things is also a pain.

I definitely vouch for a "ChemDraw Huge/Superhuge" theme as said by jtirado before.

There NEEDS to be a fix for this!

 11/9/2016 5:05 PM
User is offline View Users Profile Print this message


drc007

Posts: 43
Joined: 10/5/2009

From the ChemDraw 16 details

"ChemDraw 16 for Mac offers improved multi-monitor and Retina (high DPI) display support."

Don't know about other platforms

 6/11/2017 10:21 AM
User is offline View Users Profile Print this message


AgentK7

Posts: 5
Joined: 10/28/2016

For those with high DPI screens, I think I've found a fix!

  • Locate ChemDraw in File Explorer
  • Right click the application and select Properties
  • Click on the Compatability tab
  • Under the Settings heading, there's an "Override high DPI scaling behaviour." box, tick it
  • Click on the drop down box under it and select System
  • Click Apply
This worked for me on my Surface Pro 4 with ChemDraw 16.0, hopefully, it'll work on your Windows systems too! I feel like crying with joy after discovering this, it's changed my life as an undergrad chemist :D
You'll have to repeat this process with the rest of the ChemOffice programs. This also works for Avogadro for me, so hopefully this is a general fix for these programs that don't support high DPI screens

FuseTalk Basic Edition v4.0 - © 1999-2018 FuseTalk Inc. All rights reserved.