PerkinElmer Informatics Support Forum
Decrease font size
Increase font size
Topic Title: Issues with targeting in Batch Explorer
Topic Summary: Target experiment does not contain a section to which to link
Created On: 11/20/2009 7:42 AM
Status Post and Reply
Linear : Threading : Single : Branch
Topic Tools Topic Tools
View topic in raw text format. Print this topic.
Answer This question was answered by CS Gleb, on Friday, November 20, 2009 7:49 AM

Answer:
The reason is that some customers use Batch Explorer with “Reaction” section, and some with "Reaction W COE Integration" section.

The following configuration should be checked:

1. In the E-Notebook 9.0.3, go to Everyone -> Configuration -> Collection Types -> “Chemistry Experiment”.
2. Right click for “Collection Type Configuration”.
3. Go to “Collection Listeners” and check if you have something like “Replace Structure” listed there. When this listener is highlighted, on the right pane you should see “ENReactionExplorer9.ReplaceCellCLsnr” (without quotes or extra spaces) as a ProgID. When you click on “Custom Properties…” under the ProgID, you should select “Target Section Type:” to be "Reaction W COE Integration" (if it is the Section Type you are using for reactions), and “Target Field:” to be “Reaction”.
4. If the “Replace Structure” listener is not listed for your “Chemistry Experiment”, then please add it manually, and make sure its settings are as described above.
 11/20/2009 7:42 AM
User is offline View Users Profile Print this message


CS Gleb

Posts: 179
Joined: 2/24/2009

When creating "Chemistry Experiment As Next Step In..." Batch Explorer form tool in E-Notebook 9.0.x, the following error message appears:


---------------------------
Reaction Explorer
---------------------------
Sorry, the target experiment does not contain a section to which to link.
---------------------------
OK
---------------------------



The target experiment is actually created, but without any linkage. If you are using "View Batch Explorer", and want to "Show" -> "All Steps Of This Batch", the following message is shown:


---------------------------
Reaction Explorer
---------------------------
Molecule is not part of a series of linked reactions.
---------------------------
OK
---------------------------


-------------------------

-PerkinElmer Technical Support



Edited: 11/23/2009 at 5:57 AM by CS Gleb
 11/20/2009 7:49 AM
User is offline View Users Profile Print this message


CS Gleb

Posts: 179
Joined: 2/24/2009

Answer Answer
The reason is that some customers use Batch Explorer with “Reaction” section, and some with "Reaction W COE Integration" section.

The following configuration should be checked:

1. In the E-Notebook 9.0.3, go to Everyone -> Configuration -> Collection Types -> “Chemistry Experiment”.
2. Right click for “Collection Type Configuration”.
3. Go to “Collection Listeners” and check if you have something like “Replace Structure” listed there. When this listener is highlighted, on the right pane you should see “ENReactionExplorer9.ReplaceCellCLsnr” (without quotes or extra spaces) as a ProgID. When you click on “Custom Properties…” under the ProgID, you should select “Target Section Type:” to be "Reaction W COE Integration" (if it is the Section Type you are using for reactions), and “Target Field:” to be “Reaction”.
4. If the “Replace Structure” listener is not listed for your “Chemistry Experiment”, then please add it manually, and make sure its settings are as described above.


-------------------------

-PerkinElmer Technical Support

 6/9/2017 11:42 PM
User is offline View Users Profile Print this message


CS Gleb

Posts: 179
Joined: 2/24/2009

See configuration steps for E-Notebook 13.x.



-------------------------

-PerkinElmer Technical Support

FuseTalk Basic Edition v4.0 - © 1999-2017 FuseTalk Inc. All rights reserved.