PerkinElmer Informatics Support Forum
Decrease font size
Increase font size
Topic Title: ELN9 Enterprise and ELN Desktop use incompatible ENotebookOra9.DLL
Topic Summary: ENotebookORA9.DLL, REGSVR32, CSBR-51772
Created On: 5/23/2011 11:22 PM
Status Post and Reply
Linear : Threading : Single : Branch
Topic Tools Topic Tools
View topic in raw text format. Print this topic.
Answer This question was answered by eva li, on Wednesday, May 25, 2011 9:29 AM

Answer:

Problem: ELN9 Enterprise ENotebookORA9.DLL incompatible with ELN Desktop

A Problem occurs if ELN9 Desktop is installed on the same PC where the ELN9 Enterprise server components have been installed before. Both versions of ELN9 use a DLL named “ENotebookORA9.dll” and these DLLs are not compatible. So this is not a problem of the Installer, but of two incompatible Visual Basic DLLs having the same name.

If you install ELN Desktop after installing the ELN Enterprise client, starting ELN Enterprise will give the following error dialog: "Sorry, an error occurred while opening a client connection: while setting up connection to business tier: the progID :ENotebookORA9.OracleAuthenticator" does not implement the IENAuthenticator interface.”

This is CSBR-51772 in our bug database.

Solution: Do not install ELN Desktop on the same computer where you want to install the ELN Enterprise client. If you accidentally did it already and received the error message mentioned above, manually registering the ENotebookORA9.DLL in the DLLs subdirectory of ELN Enterprise with REGSVR32 helps.

This makes the ELN Enterprise client work again, bug after that ELN 9 Desktop won't work anymore.

 5/23/2011 11:22 PM
User is offline View Users Profile Print this message


eva li

Posts: 50
Joined: 3/20/2011

Answer Answer

Problem: ELN9 Enterprise ENotebookORA9.DLL incompatible with ELN Desktop

A Problem occurs if ELN9 Desktop is installed on the same PC where the ELN9 Enterprise server components have been installed before. Both versions of ELN9 use a DLL named “ENotebookORA9.dll” and these DLLs are not compatible. So this is not a problem of the Installer, but of two incompatible Visual Basic DLLs having the same name.

If you install ELN Desktop after installing the ELN Enterprise client, starting ELN Enterprise will give the following error dialog: "Sorry, an error occurred while opening a client connection: while setting up connection to business tier: the progID :ENotebookORA9.OracleAuthenticator" does not implement the IENAuthenticator interface.”

This is CSBR-51772 in our bug database.

Solution: Do not install ELN Desktop on the same computer where you want to install the ELN Enterprise client. If you accidentally did it already and received the error message mentioned above, manually registering the ENotebookORA9.DLL in the DLLs subdirectory of ELN Enterprise with REGSVR32 helps.

This makes the ELN Enterprise client work again, bug after that ELN 9 Desktop won't work anymore.

FuseTalk Basic Edition v4.0 - © 1999-2020 FuseTalk Inc. All rights reserved.